Back to overview
Downtime
Our datacenter is experiencing network connectivity issues
May 28, 2026 at 10:13am UTC
Affected services
App Website
Backend Website
Resolved
May 28, 2026 at 10:17am UTC
Services are operational again
Affected services
Created
May 28, 2026 at 10:13am UTC
It is being investigated by our datacenter providers
Affected services