Get in touch
Back
Maintenance

Scheduled Maintenance

Completed 4 Nov at 10:00am CET.

App Website Backend Website Database
Completed

Maintenance completed

Posted 4 Nov at 10:00am CET.
Started

⚠️ Planned maintenance and update release is scheduled for November 4, 2023, from 6:00 AM to 10:00 AM (CET). Please expect intermittent service interruptions during this time. ⚠️

Posted 4 Nov at 06:00am CET.